Project

General

Profile

Bug #781

The problem with installing Kannel

Added by Vasia Pupkini4 about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/09/2018
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

Hello everybody! I have a problem during the installation of the latest version of Kannel. I have an OS: Debian. Apparently the problem is with the Bizon package. Error code:
gcc -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -o wmlscript/wslexer.o -c wmlscript/wslexer.c
wmlscript/wslexer.c:221:32: error: unknown type name ‘YYLTYPE’
int ws_yy_lex(YYSTYPE *yylval, YYLTYPE *yylloc, void *context)
^~~~~~~
Makefile:225: recipe for target 'wmlscript/wslexer.o' failed
make: *** [wmlscript/wslexer.o] Error 1

Bison version:
dpkg -l|grep bison
ii bison 2:3.0.4.dfsg-1+b1 amd64 YACC-compatible parser generator
ii libbison-dev:amd64 2:3.0.4.dfsg-1+b1 amd64 YACC-compatible parser generator - development library

I would be very grateful if there is a solution to the problem. Thanks to all for earlier answers.

History

#1 Updated by Alexander Malysh about 1 year ago

Hi,

which Debian version are you using ?

#2 Updated by Vasia Pupkini4 about 1 year ago

Alexander Malysh wrote:

Hi,

which Debian version are you using ?

Thanks for your reply Alexander! I use Debian 9 Stretch.
You know, apparently in other distributions (at least in the Red Hat family) a similar gap will occur, since they also install the Bizon> 2.5 installation version when installing.

#3 Updated by Alexander Malysh about 1 year ago

Hi,

I don't know what the problem should be, because I'm able to build on Debian 9.

1. Install packages
apt-get update && apt-get upgrade -y && \
apt-get install -y build-essential subversion ntp nano wget cvs subversion curl git-core unzip autoconf \
automake1.11 libtool flex debhelper pkg-config libpam0g-dev intltool checkinstall docbook docbook-xsl \
build-essential libpcre3 libpcre3-dev libc6-dev g++ gcc autotools-dev bison libncurses5-dev m4 tex-common \
texi2html texinfo libxml2-dev \
openssl libssl-dev locales libmariadbclient-dev libmariadbclient-dev-compat supervisor libtool libtool-bin \
lsb-release vim

2. cd kannel_source_path
3. ./bootstrap.sh
4. ./configure with your params
5. make

#4 Updated by Vasia Pupkini4 about 1 year ago

Alexander Malysh wrote:

Hi,

I don't know what the problem should be, because I'm able to build on Debian 9.

1. Install packages
apt-get update && apt-get upgrade -y && \
apt-get install -y build-essential subversion ntp nano wget cvs subversion curl git-core unzip autoconf \
automake1.11 libtool flex debhelper pkg-config libpam0g-dev intltool checkinstall docbook docbook-xsl \
build-essential libpcre3 libpcre3-dev libc6-dev g++ gcc autotools-dev bison libncurses5-dev m4 tex-common \
texi2html texinfo libxml2-dev \
openssl libssl-dev locales libmariadbclient-dev libmariadbclient-dev-compat supervisor libtool libtool-bin \
lsb-release vim

2. cd kannel_source_path
3. ./bootstrap.sh
4. ./configure with your params
5. make

Alexander Malysh wrote:

Hi,

I don't know what the problem should be, because I'm able to build on Debian 9.

1. Install packages
apt-get update && apt-get upgrade -y && \
apt-get install -y build-essential subversion ntp nano wget cvs subversion curl git-core unzip autoconf \
automake1.11 libtool flex debhelper pkg-config libpam0g-dev intltool checkinstall docbook docbook-xsl \
build-essential libpcre3 libpcre3-dev libc6-dev g++ gcc autotools-dev bison libncurses5-dev m4 tex-common \
texi2html texinfo libxml2-dev \
openssl libssl-dev locales libmariadbclient-dev libmariadbclient-dev-compat supervisor libtool libtool-bin \
lsb-release vim

2. cd kannel_source_path
3. ./bootstrap.sh
4. ./configure with your params
5. make

Alexander, for your tip-off! I followed her and did everything according to your instructions. But in the end there was the same mistake. Error content:

gcc -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/include/openssl -o wmlscript/wslexer.o -c wmlscript/wslexer.c
In file included from wmlscript/wslexer.c:72:0:
y.tab.h:264:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wslexer.c:70:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
int ws_yy_parse(void context);
^~~~~~~~~
Makefile:225: recipe for target 'wmlscript/wslexer.o' failed
make: *
* [wmlscript/wslexer.o] Error 1

((((

#5 Updated by Vasia Pupkini4 about 1 year ago

Are you have any ideas? Big thanks in advance

#6 Updated by Alexander Malysh about 1 year ago

Hi,

unfortunately, no. As I already wrote, it works on my docker with clean Debian 9 and packages above.

Thanks,
Alex

#7 Updated by Vasia Pupkini4 about 1 year ago

Alex, big thanks for your answer! In this discuss https://redmine.kannel.org/issues/699 I found the decision for my problem! Topic is closed!

Regards,
Jamshid

#8 Updated by Alexander Malysh about 1 year ago

  • Status changed from New to Resolved

Great to hear.

Also available in: Atom PDF