Project

General

Profile

Bug #690

Redis delivery report DLR backend

Added by Lorenzo Bagni over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Bearerbox DLR handling
Target version:
Start date:
03/18/2014
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

I report the problem sent to ML User and Devel.

I've followed the problem till the
static int redis_update(void *conn, Octstr *sql, List *binds)
on gwlib/dbpool_redis.c line 315
and the bearer die on line 338
reply = redisCommand(conn, octstr_get_cstr(sql));

it looks like the function 'octstr_get_cstr' returns Panic when the % (percent) char is not correctly handled.

Hi,
I've found the problem under redis backend crash.
My dlr-url (
http://my.fqdn.name/DlrManager.aspx?oa=%p&da=%P&smsc=%i&dlrtype=%d&detail=%a&tempo=%T&id=%i&delr=%A&user=%n&foreign=%F&idgen=0|1|2|3|4|5|6) contais many parameters with values as %[char], some of this broke
/usr/bin/bearerbox, some not but store on Redis backend different values:
%p %P %T %n => PANIC
%a is stored as 0x0.07f1160003b48p-1022
%A is stored as 0x0.07f1160003b48p-1022
%F is stored as 0.000000
%i is stored as 378
%d is stored as 378

The dlr-url is passed is urlencoded, so I guess the issue is when the
bearer decode and evaluate per params sent to
http://kannel-ip:13013/cgi-bin/sendsms.

Last thing, I've tried to register under Kannel Redmine, but after
successully registration I cannot login because I've nevere recevied the
confirmation mail.
For admins: could you kinldy check my account and unlock my account?

Thanks in advance
Bagni

2014-03-12 16:06 GMT+01:00 Lorenzo Bagni <bagni at networkweb.net>:

Hi,

I've activated the REDIS_DEBUG but the HMSET command works on redis-cli,
but not with Kannel:
bearerbox.log:
2014-03-12 15:54:14 [30938] [8] DEBUG: DLR[redis]: Adding DLR
smsc=kannelfake, ts=8f3d43b4-f93c-4d8f-b681-35b658f74d90, src=51303,
dst=393280000000, mask=31, boxc=
2014-03-12 15:54:14 [30938] [8] DEBUG: Adding DLR into keystore
2014-03-12 15:54:14 [30938] [8] DEBUG: redis cmd: HMSET
dlr:kannelfake:8f3d43b4-f93c-4d8f-b681-35b658f74d90:4677782 smsc kannelfake
ts 8f3d43b4-f93c-4d8f-b681-35b658f74d90 source 51303 destination
3932800000000 service user_mobyt_fake url
http://my.fqdn.name/DlrManager.aspx31oa=%p&da=%P&smsc=%i&dlrtype=%d&detail=%a&tempo=%T&id=%i&delr=%A&user=%n&foreign=%F&idgen=0|1|2|3|4|5|6 mask NULL boxc ? status 0
2014-03-12 15:54:14 [30938] [8] PANIC: /usr/sbin/bearerbox() [0x4a810c]
2014-03-12 15:54:14 [30938] [8] PANIC: /lib64/libpthread.so.0(+0xf710)
[0x7f3d26ec0710]
2014-03-12 15:54:14 [30938] [8] PANIC: /usr/sbin/bearerbox() [0x48d431]
2014-03-12 15:54:14 [30938] [8] PANIC: /usr/sbin/bearerbox() [0x41fa63]
2014-03-12 15:54:14 [30938] [8] PANIC:
/usr/sbin/bearerbox(dlr_add_real+0x3a3) [0x41cf63]
2014-03-12 15:54:14 [30938] [8] PANIC: /usr/sbin/bearerbox() [0x457b7f]
2014-03-12 15:54:14 [30938] [8] PANIC:
/usr/sbin/bearerbox(smscconn_send+0x5f) [0x42406f]
2014-03-12 15:54:14 [30938] [8] PANIC:
/usr/sbin/bearerbox(smsc2_rout+0x428) [0x417f68]
2014-03-12 15:54:14 [30938] [8] PANIC: /usr/sbin/bearerbox() [0x418e1d]
2014-03-12 15:54:14 [30938] [8] PANIC: /usr/sbin/bearerbox() [0x491da9]
2014-03-12 15:54:14 [30938] [8] PANIC: /lib64/libpthread.so.0(+0x79d1)
[0x7f3d26eb89d1]
2014-03-12 15:54:14 [30938] [8] PANIC: /lib64/libc.so.6(clone+0x6d)
[0x7f3d25c50b6d]

History

#1 Updated by Stipe Tolj over 6 years ago

  • Category set to Bearerbox DLR handling
  • Status changed from New to Resolved
  • Assignee set to Stipe Tolj
  • Target version set to svn

Bug has been fixed in SVN trunk, along with some more improvements. See the ChangeLog entry in SVN trunk.

Please do a fresh SVN trunk checkout, test and confirm.

Stipe

#2 Updated by Stipe Tolj over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF