Project

General

Profile

Bug #682

Bearerbox store problem

Added by vikrant mhakal over 7 years ago. Updated over 7 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Bearerbox MT routing
Target version:
Start date:
02/27/2013
Due date:
% Done:

0%

Estimated time:
24.00 h
Affected version:

Description

Please find the bearerbox related information , we can call it as a Bug ,as you can see in the below display. Box was running since more than 2 hours but we lost connectivity with route. After some time route got online but there was only enquire link and deliver_sm communication. In such case box was not pushing messages which was in his global memory or new,so we restarted box and then messages went successfully.
kindly suggest how to fix the same ?

------------------------------------------------------------------------------------------------------------------------------------------------------------
This is bearerbox status page display

Kannel bearerbox version `svn-r4991'. Build `Feb 12 2013 23:42:34', compiler `4.1.2 20080704 (Red Hat 4.1.2-52)'. System Linux, release 2.6.18-308.8.1.el5, version #1 SMP Tue May 29 14:57:25 EDT 2012, machine x86_64. Hostname ns2.routesms.com, IP xxx.xxx.xxx.xxx. Libxml version 2.6.26. Using OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008. Compiled with MySQL 5.0.95, using MySQL 5.0.95. Using native malloc.

Status: running, uptime 0d 2h 26m 38s

WDP: received 0 (0 queued), sent 0 (0 queued)

SMS: received 0 (0 queued), sent 353030 (2828 queued), store size 2829
SMS: inbound (0.00,0.00,0.00) msg/sec, outbound (25.13,38.19,40.13) msg/sec

smpp_VD01[smpp_VD01] SMPP:xxx.xxx.xxx.xxx:8888/8888:rtsms:smpp (online 6196s, rcvd: sms 0 (0.00,0.00,0.00) / dlr 294 (0.10,0.03,0.03), sent: sms 160
(0.00,0.00,0.02) / dlr 0 (0.00,0.00,0.00), failed 0, queued 0 msgs)
--------------------------------------------------------------------------------------------------------------------------------------------------------

History

#1 Updated by Alexander Malysh over 7 years ago

Hi,

are you using TX and RX sessions? If so try to use TRX session or define 2 smpp groups, one for TX and second for RX.

Alex

#2 Updated by vikrant mhakal over 7 years ago

Hi,

We are using TRX only, please provide some solutions for this problem. Because we have to monitor status page continuously to avoid queue at our end

#3 Updated by Alexander Malysh over 7 years ago

Hi,

please provide debug log if this happens again.

Alex

#4 Updated by vikrant mhakal over 7 years ago

Hi Alex

In trace i can find only enquire link for both threads after getting online.
BeareBox was running for 2h 26m 38s, but route got disconnected for some minutes.
But when it got on-line, it was not sending sms from global queue.

Vikrant

#5 Updated by vikrant mhakal over 7 years ago

Hi Alex

Is there any other way round to debug or solution.

Vikrant

#6 Updated by Alexander Malysh over 7 years ago

Hi,

how we should see what happens, when we not even have logs to check?

Alex

Also available in: Atom PDF